PDA

View Full Version : 2010 Town Car sound system.



PICKUP6772
07-05-2021, 04:44 PM
Okay guys,
My Town Car is factory equipped with the six disc stereo, and 4 speaker system. I want to upgrade the system, as I do a lot of out of state traveling. The biggest issue I'm having is I can't get a straight answer on the speaker sizes. The closest thing I can figure is it has 6x8's at all four corners. I'm biased towards Kenwood, but I'm not looking to spend 1200 on the stereo that fits my needs. What I'm looking for is: Double Din - CD - USB - Navigation. Are there any other brands out there that are in the same class as Kenwood?
MIKE

sly
07-05-2021, 10:56 PM
I would consider Pioneer to be in the same class if not better than Kenwood (except the eXcelon line - that's pretty damn good). Alpine, JVC's better stuff, Blaupunkt, Sony, and a few others I can't remember right now. I can't recommend any for you as I've all but abandoned CDs in the vehicles and use my phone for navigation (Android Auto with the double din in the Expedition, phone holder in the panthers).

Mainemantom
07-06-2021, 11:23 AM
I Personally like the Kenwood, JVC and Sony stereos. Important to me with any model is being able to SEE the controls. Some of the units have remotes. That is one thing I like about factory units. I can see what I am doing.
On the newer units,I have to break out the manual and follow the instructions to do stuff.

DerekTheGreat
07-06-2021, 12:34 PM
I second Sony stereos. I've got a single DIN in my '88 that I put in many years ago but it checked all of my boxes at that time: Five band equalizer, High & low pass filters, HD radio, customizable colors (it's white with the lights off, green with them on), legacy style buttons and just overall easy to navigate & use. It's a biotch when I unplug it though, resetting everything sucks. Not sure what is available now though.

tjc78
07-06-2021, 12:42 PM
I had a Pioneer AVIC Z140 in my 04. Great unit. Navigation was decent and sound quality great as well.

You should be able to find some deals used now as itís quite a few years old now.

If you donít need CD there are many low cost options that support Apple Car Play / Android Auto.

As for the speakers pretty sure itís 6x8 all around. You can get 6x9s in the rear deck with some finesse. Arenít all 2010 TCs equipped with the Soundmark system with sub? Youíll probably need some adapters to tap into the amps for that. Check with Crutchfield for your options even if you donít buy from them.

PICKUP6772
07-14-2021, 10:30 PM
tjc78
Yes it does have the Soundmark system. I don't know about the sub. I would have to check it out, to confirm. I got the car for free from a customer 2 years ago. It was a fleet car for a limousine company, that I used to service from time to time, when I worked at my last job.
MIKE

PICKUP6772
01-03-2022, 03:10 PM
Ok guys, I'm opening this back up, as I now remember why I started it in the first place. I was driving along to NYC, and the radio shut off and reset itself to factory. It's not the first time it has happened. There have also been a few times where I'm driving with the radio OFF, and it will come on by itself at factory reset. I'm leaning towards the radio itself, but as always, am open to suggestions/recommendations.

MIKE

sly
01-03-2022, 03:35 PM
Radio itself, involving the power wires/connections/solder joints on the main board in the radio. That's the most likely issues in this case.

PICKUP6772
01-10-2022, 07:34 PM
Sly,
The stereo itself was my thought, too. I will probably replace it with the same unit, as the aftermarket stuff is just too far out of my price range right now. I'm in the middle of refurbishing my house, and there is just no extra money. Especially since the Kenwood unit, that has everything I want is around 1,200 dollars.
MIKE

sly
01-10-2022, 10:20 PM
Yeah. I have no problems taking things apart like that and looking for cracked solder joints. A little heat and fresh dab of solder goes a long way for stuff like that.