PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Page 13 of 13 FirstFirst ... 3111213
Results 241 to 251 of 251

Thread: 1988 Lincoln Town Car

  1. #241
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    38,029

    Default

    they won't shock your Sach ?

    I put KYB Excel-G's on both ends of the Continental, can't complain. They make the only front shocks that actually fit the car correctly, so that was a huge motivation. Back ones were on clearance. Of course air suspension sucks up a whole lot of shitty shock absorber action. The old front struts were wasted, one had no resistance and the other actually seized up. Thats what drove replacement, the front corner of the car got stuck down and it started riding poorly. I'm sure it had no resistance to speak of before it got stuck and I never noticed.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  2. #242
    88 LTC nfldfordltd's Avatar
    Join Date
    Oct 2005
    Location
    Conception Bay South, Newfoundland and Labrador
    Posts
    861

    Default

    Quote Originally Posted by VicCrownVic View Post
    Nice. Hopefully a good report on the new shocks, at least for your sake. I'd be curious to hear if they're too harsh/stiff or not.

    I had a set of stock replacement Gabriel's on the front of my '89 years ago, and they were awful. I couldn't tell the difference between the completely dead originals and the brand new Gabriels. That car was parked not long after those shocks were installed, but I had no intention of reusing those shocks. However, the old Gabriel Hi-Jackers on the rear of that car and the new pair on The Ice Car I found to be great. You don't need to haul a ton-o weight to benefit from air shocks, just run lower pressure in them with less weight for a manual fill setup like mine, or adjust the sensor accordingly for the optional stock setup. I think the minimum pressure recommended for the Hi-Jakers is 25 PSI, I think I run around 150 PSI (haven't touched them in 3 years since I installed them), I think max is 225 (the max is much lower on the Monroes, like 125 PSI I think, I'm at 90-100 on those). Anyway, nothing wrong with not wanting to go the air route, it's just my preference and may not work for everyone.

    Good to hear that sending unit is still working. I know Kevin discovered some of the late build '88 TCs in the JYs seem to have gotten the newer sending unit like '89 TCs got, luckily yours needed the older unit that we sent you.
    Makes sense, my car's build date is 05/88. I think the next month was when everything changed.

    Summer car-> 1988 Lincoln Town Car, triple blue, 292,xxx km. New HO 5.0 in and running. Bought 2006/08/22. June 2017 PotM!
    Winter vehicle-> 1995 Ford F-250 XLT SuperCab 4x4, 237,xxx+km. AKA "Brutus" 460/E4OD/4.10 axles and 12 MPG. Bought 2019/08/14

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  3. #243
    88 LTC nfldfordltd's Avatar
    Join Date
    Oct 2005
    Location
    Conception Bay South, Newfoundland and Labrador
    Posts
    861

    Default

    Quote Originally Posted by gadget73 View Post
    they won't shock your Sach ?

    I put KYB Excel-G's on both ends of the Continental, can't complain. They make the only front shocks that actually fit the car correctly, so that was a huge motivation. Back ones were on clearance. Of course air suspension sucks up a whole lot of shitty shock absorber action. The old front struts were wasted, one had no resistance and the other actually seized up. Thats what drove replacement, the front corner of the car got stuck down and it started riding poorly. I'm sure it had no resistance to speak of before it got stuck and I never noticed.
    I don't like it when a car that is supposed to ride nicely rides poorly.

    Summer car-> 1988 Lincoln Town Car, triple blue, 292,xxx km. New HO 5.0 in and running. Bought 2006/08/22. June 2017 PotM!
    Winter vehicle-> 1995 Ford F-250 XLT SuperCab 4x4, 237,xxx+km. AKA "Brutus" 460/E4OD/4.10 axles and 12 MPG. Bought 2019/08/14

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  4. #244
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    5,593

    Default

    Quote Originally Posted by nfldfordltd View Post
    Makes sense, my car's build date is 05/88. I think the next month was when everything changed.
    Wow, that's a late build '88! Mine is 08/87. Does your check engine light work? Mine is there, just not wired up. Heard that was a sign of an early build '88, that the later cars' CELs actually worked.
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  5. #245
    88 LTC nfldfordltd's Avatar
    Join Date
    Oct 2005
    Location
    Conception Bay South, Newfoundland and Labrador
    Posts
    861

    Default

    Quote Originally Posted by DerekTheGreat View Post
    Wow, that's a late build '88! Mine is 08/87. Does your check engine light work? Mine is there, just not wired up. Heard that was a sign of an early build '88, that the later cars' CELs actually worked.
    Mine doesn't have a CEL at all. Blank space in the panel.
    AFAIK, the 88 model year ran from spring 87 to fall 88. Hence higher production numbers for 88 than all other years of Lincolns in the 80s.

    Summer car-> 1988 Lincoln Town Car, triple blue, 292,xxx km. New HO 5.0 in and running. Bought 2006/08/22. June 2017 PotM!
    Winter vehicle-> 1995 Ford F-250 XLT SuperCab 4x4, 237,xxx+km. AKA "Brutus" 460/E4OD/4.10 axles and 12 MPG. Bought 2019/08/14

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  6. #246
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    5,593

    Default

    It's probably there like mine. And if it's like mine, it's wired up at the idiot light pod and all, just not wired up somewhere else downstream. I had mine out once upon a time and verified. I just don't know where to trace it to without hacking the dash up.
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  7. #247
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    38,029

    Default

    if you ever get a copy of the complete wiring diagram for the car, that would probably tell you where the wire ends. Short of that it turns into "exploratory surgery" to try and find it. No thank you.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  8. #248
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    5,593

    Default

    Yeah, I think it definitely requires surgery. I later found an '88 TC at a yard and hacked that up as someone already took a hacksaw to the dash. Wire went somewhere on top of the steering column and then off to the left to pass through the firewall. I lost it/gave up right around there as I knew I'd never want to go that far into my own car just for a light which, as you put it, mostly never comes on or flickers.
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  9. #249
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    38,029

    Default

    Thats basically what I did when I was considering a digital dash swap. I got a good look inside of a digi dash car in the junkyard and noped right out of that idea.

    The only possible glitch is if you live in one of those really stupid states that demands a CEL that works. I know a guy on another forum who had an 88 and had that problem. I think he ultimately fixed it by changing the light cluster to one without the CEL and going to a different inspector.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  10. #250
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    5,593

    Default

    Now that's an idea. I think I might even try that, as sometimes anal retentive me sees the CEL and knows it doesn't work. If the '87 and down pods work I might try one of those instead when I finally remove my cluster to fix the clock. Need a minty one though.
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  11. #251
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    38,029

    Default

    you could probably also take it apart and change the lens. I believe the CEL goes where my car has the "ALARM" lamp for the optional security system.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

Page 13 of 13 FirstFirst ... 3111213

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net