PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Page 3 of 3 FirstFirst 123
Results 41 to 56 of 56

Thread: low oil pressure

  1. #41

    Default

    Fan works as it should. Stop and go traffic, stays between O and the R on the gauge. Long periods of driving without stopping is when it starts giving problems. I'm planning on getting a separate tranny cooler with fan and see if that helps. And I'm in the process of doing a 3g alternator swap with electric fans and maybe a electric water pump.

    Sent from my Z956 using Tapatalk

  2. #42
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    34,471

    Default

    also possible the water pump leak is sucking air at speed, and you're not actually moving water properly.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body, 246k and counting

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  3. #43

    Default

    I'll change out the gasket and I'll update you guys on it. I'll do it maybe tomorrow after work.

    Sent from my Z956 using Tapatalk

  4. #44
    Full of Greenhouse Gas Tiggie's Avatar
    Join Date
    Mar 2006
    Location
    Moneta, VA
    Posts
    4,165

    Default

    Any gaps around your radiator and the core support?
    1988 Crown Vic Wagon - daily
    1990 Country Squire - yard ornament (save me please)
    Other: 95 Ranger, 74 F250, 68 Mustang, 94 Mustang
    Sold: 1982 LTD and 1987 Crown Vic

    GMN Box Panther History
    Box Panther Horsepower and Torque Ratings
    Box Panther Production Numbers

  5. #45
    I post a lot... knucklehead0202's Avatar
    Join Date
    Apr 2015
    Location
    Southern Commiefornia
    Posts
    1,526

    Default

    Quote Originally Posted by DerekTheGreat View Post
    There's this dude on YouTube who threw it in the crankcase of his old 2.9 Ranger and it free'd up a sticky lifter(s) in seconds.

    Typically all the Old fords I've ever driven go to the middle and stay there as if there's some sort of buffer to keep them there. In your case I wouldn't worry about it as I'd expect it to heat up at idle..
    My first '90 literally NEVER got above "O" on NORMAL except the time it shit a heater hose. When I had the top-end done on the motor they found out the whole bottom half of my radiator was full of shit and getting ready to burst. They put in a new radiator and fan clutch at that time. After a complete top-end including new aluminum heads, 1.7 rockers, intake, TB, injectors, MAF, etc. it ran cool as ever despite me beating on it and manually shifting to keep it in the radically-different powerband.

    New car had a new water pump and radiator flush shortly after I got it and it crapped the pump. Always ran around "R" before and still does. A few weeks ago on a particularly warm day, I was awaiting a pick-up/drop-off in a parking lot in the car with the A/C running for the puppies. Watched the gauge climb slowly from "R", then "M", then it hit about the middle of "A" and wavered. Went down a little, up a little, and I freaked out and shut it down. Rolled the windows down and sweated for a bit. Once we got underway again it swiftly went back down to "R" but really shook my faith. It has a new water pump and fan clutch, the coolant looks great, but i'm scared. May just stick the new radiator I tore out of the other car in there for safety's sake. Driving the boat out to the desert this weekend so we'll see how much I get done tomorrow.

  6. #46

    Default

    sorry guys no updates yet. car has a annoying gremlin that keeps draining my battery. have to fix that first since i miss driving a car with power in it instead of the slow buick.

  7. #47
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    4,023

    Default

    I had an F150 that drained the battery over night, turned out it was the alternator. Your results may vary but it's a place to start..
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  8. #48

    Default

    Well imma check the window motor first. It started happening after I put in a new one. I kept hearing buzzing coming from the driver door after turning off the car

    Sent from my Z956 using Tapatalk

  9. #49
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    34,471

    Default

    should be no power to the window motors once the key is off. Power lock motor will have power available all the time though.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body, 246k and counting

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  10. #50

    Default

    Power lock motor? My power locks never have worked since I bought the car. Where exactly is it at?

    Sent from my Z956 using Tapatalk

  11. #51
    Full of Greenhouse Gas Tiggie's Avatar
    Join Date
    Mar 2006
    Location
    Moneta, VA
    Posts
    4,165

    Default

    Quote Originally Posted by dan View Post
    Power lock motor? My power locks never have worked since I bought the car. Where exactly is it at?

    Sent from my Z956 using Tapatalk
    Inside the door below the latch. You may want to check the lock switch up on the arm rest; sounds like it may be stuck on.
    1988 Crown Vic Wagon - daily
    1990 Country Squire - yard ornament (save me please)
    Other: 95 Ranger, 74 F250, 68 Mustang, 94 Mustang
    Sold: 1982 LTD and 1987 Crown Vic

    GMN Box Panther History
    Box Panther Horsepower and Torque Ratings
    Box Panther Production Numbers

  12. #52

    Default

    Gotcha will do. Thanks

    Sent from my Z956 using Tapatalk

  13. #53

    Default

    So I took a look at the armrest and the switch next to the manual door locking mechanism was stuck downwards. Hopefully that's it for the problem. I'll take the battery to get recharged tomorrow since I don't feel like driving in this San Antonio traffic.

    Sent from my Z956 using Tapatalk

  14. #54

    Default

    Yupp it was that switch. Now she works fine

    Sent from my Z956 using Tapatalk

  15. #55
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    4,023

    Default

    Ah, simple things first.
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  16. #56

    Default

    Yes sir. Now to save up for the performance upgrades lol

    Sent from my Z956 using Tapatalk

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net