PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Results 1 to 5 of 5

Thread: ['00 MGM LS] Dash and door controls illumination quirks

  1. #1
    Member
    Join Date
    Dec 2018
    Location
    Poznan, Poland
    Posts
    21

    Unhappy ['00 MGM LS] Dash and door controls illumination quirks

    Hi,

    I've just bought a '00 MGM LS and I found some quirks in the controls and dash illumination - I will have them inspected by an electrician (who needs to convert the headlights to European beam pattern standards), but I just wanna pinpoint the causes before I get the job done:

    The symptoms:
    1) The dash control buttons, e.g. Rear Window Defrost, the EATC buttons, and the door-mounted seat controls, and the headlight (main lamp) switch) ARE NOT illuminated. They work fine, though.
    2) The radio head unit display and buttons are illuminated and work fine.
    3) The EATC display works, and the buttons are responsive.
    4) The ashtray/cupholder drawer is not illuminated.
    5) All other interior illumination (courtesy and vanity) works.
    6) The door latch/window buttons on the doors are illuminated.

    What gives? I read the wiring diagrams, though I'm unsure how the power is distributed to those components which are not illuminated. I thought they get power from their respective wire harnesses and connectors. Perhaps there is a faulty hot line before the voltage for the this illumination is distributed to the components, but I just don't know.

    Could there be something unplugged? A blown fuse in the cabin fuse box or the battery fuse/relay box?
    There's also non-stock wiring work, e.g. an additional 12-V cig-style power outlet in the right footwell; there are traces of a deleted phone/loudspeaker system and a mobile charging dock (some old Nokia, I guess). The LCM works fine. The headlights got the bulbs converted to some awful LEDs, which will be deleted and converted back to filament bulbs.
    Last edited by SpitShine_PL; 12-27-2018 at 03:41 AM.

  2. #2
    Member BlackVic_P71's Avatar
    Join Date
    Sep 2013
    Location
    New York
    Posts
    573

    Default

    The EATC has replaceable bulbs, the door mounted seat controls do not light up. The defrost button has LEDs inside which may have burned out. Headlight switch has a tiny bulb in it that is almost always burned out in just a few years.

    LOUD EXHAUST IS FUN! AM I SHOUTING?
    Last edited by BlackVic_P71; 12-27-2018 at 09:04 AM.
    1989 Country Squire - Twilight Blue, 347 stroker


    2005 Crown Victoria Sport - Black - Stainless Works full exhaust with Borla Pro XS mufflers, BBK 75mm TB, Accufab plenum, CVPI airbox, Heinous control arms, etc...

  3. #3
    Member
    Join Date
    Dec 2018
    Location
    Poznan, Poland
    Posts
    21

    Default

    OK, I see.
    So, the EATC in 2000 MGMs is the pre-revision version with replaceable bulbs, right? The newer ones have those pesky "revised" lights (LEDs?) that cannot be twisted and popped out for replacement.
    I imagine that the ashtray/cupholder light might be dead, too, or disconnected.

    PS. Yeah, I got a pair of Magnaflows to make the LS rumble and purr louder.
    Last edited by SpitShine_PL; 12-27-2018 at 09:36 AM.

  4. #4
    Member
    Join Date
    Dec 2018
    Location
    Poznan, Poland
    Posts
    21

    Default

    BTW. Getting a new headlight switch. AFAIK, I can't find those mini-bulbs for the EATC. They seem to be on eBay only. Are there any replacements? I found these on Amazon, the bulb base looks almost the same.
    https://www.amazon.com/cciyu-Halogen...ype=automotive

  5. #5
    Member
    Join Date
    Dec 2018
    Location
    Poznan, Poland
    Posts
    21

    Default

    Updating this thread with a solution, for I don't like loose ends.

    The best replacement bulbs for the EATC with the backlight filament bulbs that CAN BE REMOVED are simply green LEDs with the Neo Wedge base, size T4; the base diameter is ca. 9.5 mm and the overall height is 12 mm. See below.
    [The image shows size T4.2, the base diameter of which is ca. 10 mm to 10.2 mm, give or take.]

    Click image for larger version. 

Name:	s-l300.jpg 
Views:	3 
Size:	20.3 KB 
ID:	51450

    NOTE: LEDs are polarity dependent. I've seen people cussing about DAT DAMN LED THING NOT WORKING, ZERO OUT OF FIVE STARS!!!. So yeah, you need to figure out which wires are the positive and the negative one.
    Normaly, you have the pole legs of a LED exposed, and one is longer: this is your positive pole, or anode. The negative pole is called cathode.

    With the T4 base already fitted to your LED, you can't see which leg is longer, even if you carefully unwind the wires from the base. However, you can see the anode and cathode tips embedded in the plastic. The legs are connected in the plastic with a bridge that is seems to be cut diagonally and off-center, leaving one side of the gap smaller. The small bit is the positive (anode), the large one (which looks like a flag) is the negative (cathode).

    Click image for larger version. 

Name:	7581017100_1316195720.png 
Views:	1 
Size:	14.3 KB 
ID:	51452

    If you are unsure, grab a power adapter (I mean any power adapter) that outputs 12 VDC, and having a female plug on it is best. There should be a polarity diagram shown on the adapter's housing (usually the plug's outer ferrule is (-), the inner ferrule is (+)). Carefully unwind the legs from the LED base and touch the female plug's ferrules according to the polarity; the LED should glow. And that's it, you've tested it and know what the polarity assignment is.

    I will install my T4s when the wooden dash strip arrives with a new main light switch.
    Attached Thumbnails Attached Thumbnails led_opis.jpg  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net