PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Page 2 of 2 FirstFirst 12
Results 21 to 30 of 30

Thread: 2006 Lincoln Town Car - Signature Limited

  1. #21

    Default

    Nick,
    I'm back in town for a week or so. It seems you've been adding to the stable in the last few years. Congratulations on your progress with the town car restoration. What's the story about the e39 touring? I don't see many above average condition examples of those.
    Jim

  2. #22
    Member EaOutlaw1969's Avatar
    Join Date
    Feb 2018
    Location
    West lake Worth Florida ( Palm Beach County )
    Posts
    636

    Default

    Nice looking car and fun project to get into. I cringed when I saw where it came from Michigan and Copart. At least you had it checked out before hand.

    Some dirt bags will buy a vehicle on that site do a couple quick hacks to make the vehicle look like a easy fix then sell it through Copart again at a major profit to unsuspecting people that are not smart enough to have it looked over first before buying.
    2007 Ford Crown Victoria LX Sport

  3. #23
    Southern
    Join Date
    Apr 2013
    Location
    Columbia, SC
    Posts
    847

    Default

    The e39 I purchased a couple of years ago. I've driven it maybe 500 miles? It sits in the garage. The timing chains, guides, and vanos sprocket seals need replacing. Nothing has jumped timing but the M62TU is a ticking time bomb if I don't replace them. Then the front suspension needs a refresh as the struts have leaked out, and 1/2 the rubber crap up front has disintegrated.

    Yea It's a rusty car, but not a rotted junker. That's the reason I got it - has the right colors, easy to learn about body panel/fitment/alignment, and the interior literally smells new. I'm still in awe about that. I'm replacing various parts under the car (just like body panels) with non rusty fasteners or replacement pieces. I've definitely seen a few people pulling a quick flip on Copart. Sad. The $100 I paid the guy to go look at it was worth it.
    -Nick M.
    Columbia, SC

    66 Squire, 89 Colony Park, 90 TC, 03 (2x) TC, 06 TC, 07 TC
    03 BMW 540iT, 05 GMC Yukon (tahoe)

  4. #24
    Southern
    Join Date
    Apr 2013
    Location
    Columbia, SC
    Posts
    847

    Default

    So I replaced the calipers (junkyard southern ones), pads (motorcraft), and rotors (coated motorcraft).

    I went to use the brakes after replacing and the pedal went to the floor. W T F. I used my Motive power bleeder - pushed fluid through. Mild improvement, still poor. Gave up. Last night, tried doing a ABS Service bleed with ForScan. Gained half the pedal back. Ran it again - no change!

    So thought about it - and devised a plan. So tonight, Applied pressure with my bleeder (15psi) at the reservoir. Full of fluid. Then used the ABS Service bleed following on screen instructions. Went to take it for a drive - it drives like these cars did when they were new, perfect pedal feel and reaction. Very very pleased. And of all things, the e-brake works!!! No frozen cables, shocker.

    Replaced the power steering pressure line (pinhole), and unfortunately a pump too - the stupid mounting threads in the shaft had too much corrosion and stripped out with the puller/pusher tool. A used Floridian pump fixed that. I filled the shaft with fluid film. I soaked the backing plates where the rotor mounts with fluid film. All that's left is replacing the gas tank (someone crunched it in the middle???), sending unit (no longer works). Quality is not the same on the 2006s. 2003s and 4s were better. Alignment and all other fluids have been done/serviced.
    -Nick M.
    Columbia, SC

    66 Squire, 89 Colony Park, 90 TC, 03 (2x) TC, 06 TC, 07 TC
    03 BMW 540iT, 05 GMC Yukon (tahoe)

  5. #25
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    5,679

    Default

    I put fluid film/Krown T40/Antisieze everywhere I can upon reassembly. Hate rusty fasteners and rust in general.
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  6. #26
    Southern
    Join Date
    Apr 2013
    Location
    Columbia, SC
    Posts
    847

    Default

    I've been commuting with this car to work, taking it on errands etc. No complaints really -just need to fix the gas pump, tidy up some trim and I will definitely list for sale. See if someone wants to compensate for time/effort....
    -Nick M.
    Columbia, SC

    66 Squire, 89 Colony Park, 90 TC, 03 (2x) TC, 06 TC, 07 TC
    03 BMW 540iT, 05 GMC Yukon (tahoe)

  7. #27
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    5,679

    Default

    Quote Originally Posted by TecNickal View Post
    .. See if someone wants to compensate for time/effort....
    Hahahahahaha ::takes a breath:: Ahahahahahaha! Wishful thinking my friend.
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  8. #28
    Southern
    Join Date
    Apr 2013
    Location
    Columbia, SC
    Posts
    847

    Default

    Yea. I know lol
    -Nick M.
    Columbia, SC

    66 Squire, 89 Colony Park, 90 TC, 03 (2x) TC, 06 TC, 07 TC
    03 BMW 540iT, 05 GMC Yukon (tahoe)

  9. #29
    GMN Regular DerekTheGreat's Avatar
    Join Date
    Sep 2014
    Location
    Warren, MI
    Posts
    5,679

    Default

    Well, as I've been told in a different thread, "..you can't value your time in what's known as a a labor of love.." or some shit like that haha. So you're supposed to help the next guy out and accept a loss. It's rust free right? That's instantly +$2,000 to asking price at least! Doesn't even have to run!
    1985 LTD Crown Victoria - SOLD
    1988 Town Car Signature - Current Party Barge

  10. #30
    Southern
    Join Date
    Apr 2013
    Location
    Columbia, SC
    Posts
    847

    Default

    Well I am glad i replaced the tank and straps. One strap was paper thing under the paint, the other strap was marginal. The tank was corroded. Garbage. So replacement junkyard tank, new sending unit and....its still not working. ARGGGGGGGGGGGGGGGG. going to ohm the sending unit this weekend and see whats going on. At least its super easy to service.
    -Nick M.
    Columbia, SC

    66 Squire, 89 Colony Park, 90 TC, 03 (2x) TC, 06 TC, 07 TC
    03 BMW 540iT, 05 GMC Yukon (tahoe)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net