PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Page 2 of 2 FirstFirst 12
Results 21 to 37 of 37

Thread: No Radio Illumination

  1. #21

    Default

    Iíll do that when I can. There must be a broken wire somewhere.


    Sent from my iPhone using Tapatalk

  2. #22
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    39,559

    Default

    if it was the 4 button radio it possibly never had the connection there.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  3. #23

    Default

    Thatís what Iím thinking the most likely scenario. If I find a nice 4 button radio Iíd snatch it up. Otherwise Iíll run my 6 button. I have 3 of them and the best looking one has a dead left channel. Iím thinking about sending it out to be rebuilt if itís not going to be too expensive.


    Sent from my iPhone using Tapatalk

  4. #24
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    39,559

    Default

    I can tell you the 6 button has a better tuner in it. The old 4 button in my Conti fuzzes a lot. I remember the same issue from the original in the Towncar way back when I got the car.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  5. #25

    Default

    Well there goes that lol. I called a place that rebuilds radios so I could get the nicest one I have rebuilt and he quoted around $300! I guess most places send them out to a third party rebuilder so the price is pretty much the same across the board. I found a remanufactured one on ebay but itís 250 bucks. Eh I think Iíll keep running what I have. Most likely aftermarket is in my future but for now I like the oem look.


    Sent from my iPhone using Tapatalk

  6. #26
    fomoco panthers !
    Join Date
    May 2011
    Location
    Bangor,Maine
    Posts
    3,258

    Default

    That price is terrible especially if it is just to replace a light bulb. Yes most places don't say they send them to a rebuilder in NY or somewhere. I am sure they double the price for their effort. I tried to get one fixed here too. Same thing, no way. If you can find a local small business that actually works on the stuff, In Ca. I knew a person that fixed radios while you waited unless parts had to be ordered. That was 20+ years ago though. I bought an extra, new TC radio faceplate which I still have from him.

  7. #27

    Default

    Yeah Iím not sure what all that entailed but I assume not much. Funny you say New York, the place I called says they send them to United Radio or something in Syracuse. They must be the main rebuilder in the US. Itís sad but no one in my area rebuilds these from my research. Maybe there is a mom and pop electronics store local that I havenít found yet. I hope so.


    Sent from my iPhone using Tapatalk

  8. #28
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    39,559

    Default

    United Radio also does clusters and assorted other auto electronics overhauls.

    There isn't that much inside these things. They are annoying to work on but its not exactly rocket science to re-cap one and put tape deck belts in. Its the time involved to come up with the cap list and then to swap them.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  9. #29

    Default

    What usually goes bad in them?


    Sent from my iPhone using Tapatalk

  10. #30
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    39,559

    Default

    capacitors mostly, but if its got a dead channel it possibly lost an output chip. I had one I had to toss. Some internal chip that does the switch from AM/FM/tape was bad on one channel. Pulled one from a similar but not compatible radio and found some other chip on the FM side was messed up so it had a weak channel. All the caps had leaked, the board had lots of corrosion on it. Best guess is the board itself was internally leaky, or the crap from the caps got inside the chip and killed it. Since most of those parts are proprietary and basically cannot be had it wasn't fixable. I pulled the new caps and the correct color faceplate light stuff out and put it in another radio that worked.

    honestly if you've got one that is pretty but broken and one that works but is ugly, swap the pretty parts over and run the functional unit. The faceplate should only be a few screws to swap.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  11. #31
    fomoco panthers !
    Join Date
    May 2011
    Location
    Bangor,Maine
    Posts
    3,258

    Default

    Just be very careful of the wires that look like a tape strip with a connector.VERY fragile. Especially one that is in a radio that has been in the heat all it's life. I broke one recently. It was brittle and crumbled. Sometimes there is point reached where buying a nice aftermarket stereo is the best way to go. Even though I really like the factory look of the TC stereo, The Kenwood replacements I bought fit and work well.

  12. #32

    Default

    Iíve taken apart 4 radios and I can tell you though outside they look similar, internally theyíre not so I donít know if much would swap over. I originally tried to swap the face plate over to the good radio but they wouldnít swap over. Even the button placement and position of the leds is different. The nicest one I have I installed today, I noticed that not only does the right channel not work but fade does not work all the way set to rear speakers. A little annoyed but hey what can I do. If I knew what components were where I might be able to Frankenstein one together lol.






    Sent from my iPhone using Tapatalk

  13. #33
    I post a lot...
    Join Date
    Dec 2011
    Location
    Yonkers NY
    Posts
    4,173

    Default

    Yea I see one has the L/D switch.
    "X" car 89 Colony Park LS Mods>Engine delete, SS duals magnaflow hflow cats, 2010 Must GT mufflers, auto air shocks, Posi, Tran cooler, big front brakes, 03+ rear disks, Large 3g alt, Tripminder, GS grill, 86 seats, 16" HPP wheels, winter boots=96 Cartier wheels, 215-65/16 Goodyear ULTRA GW3 snows, pi rear sway, alum driveshaft.
    03 Marauder DBP, HS, 6disk, Organizer, Silver Stars, M&Z rear control arms, Oil deflector.
    02 SL500 Silver Arrow
    08 TC Signature Limited, HID's Mods>235/55-17 Z rated Cooper Zeon RS3-A, Addco 1" rear Sway, Posi, Compustar Remote Start, floor liners, trunk organizer, Winter=05 Mustang GT rims, Nokian Hakkapeliitta R-2 235/55-17

  14. #34

    Default

    That one is actually out of a thunderbird. Itís a little ugly but it works. Iíll run it until I can get one that looks good and works well.


    Sent from my iPhone using Tapatalk

  15. #35

    Default

    I took the connector apart today and found that if I jumped the G/Y wire with the Y/BK nothing happens. According to the manual I have both should have 12v with the ignition on but that would indicate neither do. So I jumped the O/BK with the Y/BK and the bulb came on. The bulb fell out and I tried adjusting the pins to make better contact but I ended up shorting out the circuit and blowing a fuse so itís still not on lol but it will be. Kind of strange how mine has the right colors but no power to them. Oh well it works thatís all I care about. Iíll run it the way it is until I get another one rebuilt.





    Sent from my iPhone using Tapatalk

  16. #36
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    39,559

    Default

    looks like 3rd up from the bottom, which is what the service manual says. Pin position more important than the wire color.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  17. #37

    Default

    After looking over all the fuses and realizing theyíre all fine, I believe the circuit is dead. Ugh whatever Iím done screwing with this damn thing for the time being.


    Sent from my iPhone using Tapatalk

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net