PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Results 1 to 3 of 3

Thread: Power front seat motor issues

  1. #1
    Donkeylips 89LincolnTWNcar's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    1,398

    Default Power front seat motor issues

    So on my Lincoln the front seat motor that tilts the seat bottom up in the rear has gotten stuck at the top of its travel... making an awkward seating position all the time... I have banged on the motor with a rubber hammer while someone operated the switches but to no avail. The front seat bottom tilt works fine, it is just the rear tilt... any ideas as to how to get it working again?
    1989 Lincoln Town Car - "Anabelle" - Original block, .030 over with SpeedPro pistons, rods fitted with ARP hardware, FRPP +volume oil pump, GT-40 3bar heads, Crane 1.72 rockers, 89' Fox cam, 93' Cobra lower intake, Explorer upper and 65mm TB, 93' Lightning EGR spacer, K&N intake kit from a 4.0L Ranger, 19lb/hr injectors w/ 87 Mark VII ECM, cat/smog deletes, Big Brake conversion, 3.55 K-Code Trac-Lok/Disc brake rear axle, CVPI LCA's w/1" sway bar in rear, wagon front sway bar, BBK 2.5" off-road H-Pipe, Flowmaster super 40s, HPP wheels, 3G alternator w/LMR.com wiring kit, gear reduction starter conversion, Best 1/4 time: 16.0 @ 85mph.

  2. #2
    Beater gonna beat sly's Avatar
    Join Date
    Mar 2010
    Location
    Lewisville, TX
    Posts
    22,714

    Default

    Probably need to take the gearset apart and check for bits clogging up the works. Clean and re-lube. The only other issues could be a dead motor, dead spot on the brushes/commutator on that motor, or a wire came loose. I've had the loose wire issue on the passenger side of my 93 once.

    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -- Albert Einstein
    rides: 93 Crown Vic LX (The Red Velvet Cake), 2000 Crown Vic base model (Sandy), 2003 Expedition (the vacation beast)
    Quote Originally Posted by gadget73
    ... and it should all work like magic and unicorns and stuff.
    Quote Originally Posted by dmccaig
    Overhead, some poor bastards are flying in airplanes.

  3. #3
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    40,979

    Default

    are you sure its mechanically jammed and not just the switch being stupid? If the lights don't dim when you hit the switch, its probably not even trying. When I got mine, the switch only worked in the wrong directions. I could make the car less comfortable but thats it. Took the switch apart and fished paper between each of the contacts to clean it, problem went away.

    if you pull the switch out, push on the axles of the switch paddles to get them to come out. Once those are out, remove the rubber cover and you can get into the contacts. Strips of regular paper dipped in alcohol should be all you need to clean it. I've never had much luck just spraying them with contact cleaner. That also dissolves all the grease which makes a mess.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net