PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Page 35 of 35 FirstFirst ... 25333435
Results 681 to 691 of 691

Thread: My 1987 Mercury Colony Park

  1. #681
    Lost and driftin' Arquemann's Avatar
    Join Date
    Jul 2019
    Location
    Finland
    Posts
    748

    Default

    Is the only difference on '90-'91 vs earlier door panels that speaker grille? I want to learn, I want to know it all! All the little things! All the things!
    I don't mind my door panels but I've seen those super ornamental ones which are really cool.
    1985 Mercury Grand Marquis LS, "Maisa"
    2008 BMW 530d Touring, "Femma"

  2. #682
    Beater gonna beat sly's Avatar
    Join Date
    Mar 2010
    Location
    Lewisville, TX
    Posts
    22,217

    Default

    IIRC... That speaker housing was the premium sound door speaker. 88-91 also had the option of a door pocket when the normal sound system with dash speakers was used.

    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -- Albert Einstein
    rides: 93 Crown Vic LX (The Red Velvet Cake), 2000 Crown Vic base model (Sandy), 2003 Expedition (the vacation beast)
    Quote Originally Posted by gadget73
    ... and it should all work like magic and unicorns and stuff.
    Quote Originally Posted by dmccaig
    Overhead, some poor bastards are flying in airplanes.

  3. #683
    2 decades of DDing Box Panthers, now in a Whale VicCrownVic's Avatar
    Join Date
    Nov 2012
    Location
    Shelby Township, MI
    Posts
    3,474

    Default

    Standard sound system '90-'91 had those speaker housing pods. Premium had the same pods with a "Premium Sound" emblem on them in the spot where the standard sound pods had "Stereo" stamped. The optional door pockets were probably not an option starting in '90 because of the new speaker pod design. Dash speakers went away in '90 and you only got the door speakers.
    Vic

    ~ 1998 Mercury Grand Marquis LS - new DD
    ~ 1991 Mercury Grand Marquis LS "The Scab" - plenty of rot, summer DD
    ~ 1997 GMC Yukon - wannabe winter DD - returning sometime in the 2020s, I finally have an engine
    ~ 1991 Mercury Grand Marquis GS "The Ice Car" - Rotting Retired Winter DD
    ~ 1989 Mercury Grand Marquis GS - Rotting Retired DD
    Gone but not forgotten:
    ~ 1988 Country Squire ~ 1987 Ford Crown Vic

  4. #684
    Member WagonMan's Avatar
    Join Date
    Sep 2004
    Location
    Bridgewater Ct.
    Posts
    736

    Default

    Quote Originally Posted by Arquemann View Post
    Is the only difference on '90-'91 vs earlier door panels that speaker grille? I want to learn, I want to know it all! All the little things! All the things!
    I don't mind my door panels but I've seen those super ornamental ones which are really cool.
    Another thing to keep in mind is on cars with vent windows, the first 11 inches of the dew wipe is cut off for the vent window assembly. If you find a set of used door panels and they have been cut, they won't work for a car without vent windows. WagonMan
    1990 Colony Park
    1970 HEMI Superbird

  5. #685
    Road Warrior Kodachrome Wolf's Avatar
    Join Date
    Nov 2014
    Location
    Evans, GA
    Posts
    1,773

    Default

    Quote Originally Posted by 87gtVIC View Post
    I like the cloth look. Wish I pulled a set back in 09 when I had the chance. Same color and all for my two door.

    Looking great.

    Did you have to drill/file out square some holes for the two pegs of the speaker pods on the 90/91 pod to fit into the door?
    So one of the two upper holes for the pegs are already present, at least on an early '87 car. I did trim off the other peg though since I wasn't drilling a large hole like that. The little clip end of the peg was kinda tired on both, so I shimmed them with a piece of paper between the tabs, so they latched well. I did have to drill two small holes for the screws at the bottom. Overall, they fit nicely and don't move around/rattle, so I'm good with that.

    Quote Originally Posted by WagonMan View Post
    Another thing to keep in mind is on cars with vent windows, the first 11 inches of the dew wipe is cut off for the vent window assembly. If you find a set of used door panels and they have been cut, they won't work for a car without vent windows. WagonMan
    I had to trim these since I don't think vent windows were available after '89. That said, this wasn't a factory vent window car though. The biggest tell is proper vent window cars have some extra bolts on the exterior of the door frame along the A-Pillar, but that wasn't done when these were swapped in (not a fan of having to drill a bunch of extra holes), however I haven't had any issues with them being fitted like that. They fit snugly in the channel and are retained with a single bolt in a factory location within the door itself.


    So two things happened today: 1.) The driver's window came back to life along with the speaker. Didn't do anything, it just worked this morning when I left for work, and was still going when I went home. Weird, but okay. Passenger side doesn't go, so still gotta test that; 2.) The radio doesn't like the heat. It'll work for a minute or two, and then it's out. Doesn't matter how much you fiddle with it, it won't go. Shame since it looks kinda neat, but I like my tunes, so I'll have to find a replacement.

    My Cars:
    -1964 Comet 202 (116K Miles) - Awaiting Resurrection
    -1987 Grand Marquis Colony Park LS (325K Miles) - April 2017 + September 2019 POTM Winner
    -1997 Grand Marquis LS (222K Miles) - The Daily Workhorse & March 2015 + January 2019 POTM Winner

  6. #686
    Wagon Addicted Tiggie's Avatar
    Join Date
    Mar 2006
    Location
    Bedford, VA
    Posts
    6,242

    Default

    Door panels look nice. Sad news on the radio. I was hoping it would get ironed out and work. On high mileage vehicles, I have seen the wires break in the door jamb. Sometimes they have enough contact to work, other times not. Might be something to check.
    1990 Country Squire - weekend cruiser, next project
    1988 Crown Vic LTD Wagon - waiting in the wings

    GMN Box Panther History
    Box Panther Horsepower and Torque Ratings
    Box Panther Production Numbers

  7. #687
    fomoco panthers !
    Join Date
    May 2011
    Location
    Bangor,Maine
    Posts
    3,780

    Default

    You could have the radio rebuilt. Finding a good used without any problems is getting harder to find. I have allot of radios. I used to be able to test them as I used to have the connectors. Would be nice to get rid of these radios.I just hate to sell something I am not sure works right.

  8. #688
    Road Warrior Kodachrome Wolf's Avatar
    Join Date
    Nov 2014
    Location
    Evans, GA
    Posts
    1,773

    Default

    The wagon has temporarily lost its garage space while I'm working on this '99 CV, so it gave me an excuse to drive it. It started kinda funny in the morning and the engine bogged down before it caught back up, and it did it right as the A/C compressor engaged. Ran fine to work. Fired it up to go home for lunch, and everything was cool until I was turning into the neighborhood and the AMP light came on. I pull into the driveway and break out the multimeter and I catch a whiff of overcharging battery.

    Damn alternator is putting out 19.6V! I just installed a brand new one a few months ago. I'm wondering if that voltage was enough to get the AMP light to illuminate since it wasn't as bright as KOEO. Anyway, that's gonna be a warranty swap. Might get a replacement this weekend, so I'm just cruising the '97.


    Also, totally unrelated, I checked the ECU for codes a few weeks ago and the EGR and VSS were coding out for no activity. Dumb question, but does a '88+ Mark VII ECU need a VSS+/- feed piped to it to make the EGR work properly? If it does, I'll grab a ECU pin out, get some donor pins, and go tap the VSS feed and get that going to make it happy.

    My Cars:
    -1964 Comet 202 (116K Miles) - Awaiting Resurrection
    -1987 Grand Marquis Colony Park LS (325K Miles) - April 2017 + September 2019 POTM Winner
    -1997 Grand Marquis LS (222K Miles) - The Daily Workhorse & March 2015 + January 2019 POTM Winner

  9. #689
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    40,248

    Default

    Yes. I don't know why exactly, but the EGR doesn't work right with no VSS on an 88+ ECM.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  10. #690
    Road Warrior Kodachrome Wolf's Avatar
    Join Date
    Nov 2014
    Location
    Evans, GA
    Posts
    1,773

    Default

    Quote Originally Posted by gadget73 View Post
    Yes. I don't know why exactly, but the EGR doesn't work right with no VSS on an 88+ ECM.
    Cool, that's what I need to know. I guess I'll find a harness at the junkyard next time and steal some pins from one unless someone has a EEC-IV connector laying around.

    Went to check the alternator situation, and that sumbitch dead. Battery registered 0.13v, so that alternator is definitely shorted out. Guess I'll haul that stuff to work tomorrow and get replacements. If this happens again with the alternator, I'll likely go back to a 3G unit. I only find it surprising that it's not playing nice here, despite the fact I've 6G swapped the '97 from its factory 3G and its been very reliable.

    My Cars:
    -1964 Comet 202 (116K Miles) - Awaiting Resurrection
    -1987 Grand Marquis Colony Park LS (325K Miles) - April 2017 + September 2019 POTM Winner
    -1997 Grand Marquis LS (222K Miles) - The Daily Workhorse & March 2015 + January 2019 POTM Winner

  11. #691
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    40,248

    Default

    I remember going through the EGR / VSS thing on my car. Tried for a long time to figure out why it never worked like it should, asked questions, got nothing but crickets. Finally figured it out, basically I connected the VSS to see what it would do because I was totally out of ideas. Posted my findings, and of course got that one smarmy dickbag responding "well of course its required, only an idiot doesn't know that, blah blah blah".

    the specific problem I had was the EGR wouldn't open when driving. It would pass a self-test. I don't remember if it set codes though. When I fixed the wiring, the EGR went full open just off-idle. That was a sticky EVR. A snort of WD40 in the solenoid got that to behave, but I did replace it. Now the EGR works and doesn't make the engine stumble.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

Page 35 of 35 FirstFirst ... 25333435

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net