Announcement

Collapse
No announcement yet.

My 1983 Continental Mark VI!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Has anyone here ever changed the antenna motor on one of these? I have a NOS one coming. But I havenít really looked at how the old one is held in.
    2002 Mercury Grand Marquis LSE, Sylvania Zevo LED Headlights, MSD Blaster Coils, K&N Cold Air Intake, Dual Exhaust, 3.27's - Dally Driver

    1983 Lincoln Continental Mark VI, Smog Delete - Summer Cruiser


    ‚Äč

    Comment


      #32
      Beautiful Lincoln! That's gonna be a nice boulevard cruiser/show car.

      Comment


        #33
        Originally posted by Lutrova View Post
        Box TCs have them too. Mine has two per seat, one forward and one back.
        Originally posted by mercurygm88 View Post
        I guess I’ll have to crawl under there and see how many bulbs there are.
        Originally posted by gadget73 View Post
        more upscale Towncars had it, cheapie base models did not. Wiring was there though. The lights under my Mark VI Signature seats plugged right in.
        Fun fact about those lights....the mounting points are present on cvs and grand marquis seat bottoms. The harnesses are not though. I installed them into my car.
        ~David~

        My 1987 Crown Victoria Coupe: The Brown Blob
        My 2004 Mercedes Benz E320:The Benz

        Originally posted by ootdega
        My life is a long series of "nevermind" and "I guess not."

        Originally posted by DerekTheGreat
        But, that's just coming from me, this site's biggest pessimist. Best of luck

        Originally posted by gadget73
        my car starts and it has AC. Yours doesn't start and it has no AC. Seems obvious to me.




        Comment


          #34
          There are a couple motors so make sure you have the right one. early vs late, 2 wire vs 3. There is some way of converting from one to the other but offhand I don't know what it is.

          pop the trim piece off the outside. Under that you'll find a nut that holds it in place. Inside the trunk there is a bracket off the side of the motor that screws to a brace in the trunk. basically unplug stuff and remove the fasteners and it comes out. Not involved at all.

          Whats actually wrong with it? The masts can be replaced, but again differences from early to late. If it doesn't operate, make sure the switch or relay is good. Not sure what the 83 used for that. My 84 Conti is auto up / auto down using this goofy relay that is triggered off the power wire for the premium sound amp. If that happens to be the case on the 83, and if they didn't hook up the trigger wires properly it won't run the antenna.
          86 Lincoln Town Car (Galactica).
          5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

          91 Lincoln Mark VII LSC grandpa spec white and cranberry

          1984 Lincoln Continental TurboDiesel - rolls coal

          Originally posted by phayzer5
          I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

          Comment


            #35
            Originally posted by gadget73 View Post
            There are a couple motors so make sure you have the right one. early vs late, 2 wire vs 3. There is some way of converting from one to the other but offhand I don't know what it is.

            pop the trim piece off the outside. Under that you'll find a nut that holds it in place. Inside the trunk there is a bracket off the side of the motor that screws to a brace in the trunk. basically unplug stuff and remove the fasteners and it comes out. Not involved at all.

            Whats actually wrong with it? The masts can be replaced, but again differences from early to late. If it doesn't operate, make sure the switch or relay is good. Not sure what the 83 used for that. My 84 Conti is auto up / auto down using this goofy relay that is triggered off the power wire for the premium sound amp. If that happens to be the case on the 83, and if they didn't hook up the trigger wires properly it won't run the antenna.
            The one I ordered is the same part number and two wire like the one in the car. It uses a dash switch to the right of the climate controls. I have power going to the motor but it does nothing.
            2002 Mercury Grand Marquis LSE, Sylvania Zevo LED Headlights, MSD Blaster Coils, K&N Cold Air Intake, Dual Exhaust, 3.27's - Dally Driver

            1983 Lincoln Continental Mark VI, Smog Delete - Summer Cruiser


            ‚Äč

            Comment


              #36
              so it has one power for up and one for down with a ground through the body?
              03 Marauder DPB, HS, 6disk, Organizer Mods> LED's in & Out, M&Z rear control arms, Oil deflector, U-Haul Trans Pan, Blue Fuzzy Dice
              02 SL500 Silver Arrow
              08 TC Signature Limited, HID's Mods>235/55-17 Z rated BFG G-Force Comp-2 A/S Plus, Addco 1" rear Sway, Posi Carrier, Compustar Remote Start, floor liners, trunk organizer, Two part Sun Visors, B&M Trans drain Plug, Winter=05 Mustang GT rims, Nokian Hakkapeliitta R-2 235/55-17
              12 Escape Limited V6 AWD, 225/65R17 Vredestein Quatrac Pro, Winter 235/70-16 Conti Viking Contact7 Mods>Beamtech LED headlight bulbs, Husky floor liners

              Comment


                #37
                Originally posted by jaywish View Post
                so it has one power for up and one for down with a ground through the body?
                I have no idea how it works. I donít normally mess with electrical stuff. It has a red wire and a light green wire.
                2002 Mercury Grand Marquis LSE, Sylvania Zevo LED Headlights, MSD Blaster Coils, K&N Cold Air Intake, Dual Exhaust, 3.27's - Dally Driver

                1983 Lincoln Continental Mark VI, Smog Delete - Summer Cruiser


                ‚Äč

                Comment


                  #38
                  I got the new power antenna installed and working today. That took all off maybe 20 minutes.

                  Now Iím just waiting on the little switch cover I ordered thatís missing.
                  2002 Mercury Grand Marquis LSE, Sylvania Zevo LED Headlights, MSD Blaster Coils, K&N Cold Air Intake, Dual Exhaust, 3.27's - Dally Driver

                  1983 Lincoln Continental Mark VI, Smog Delete - Summer Cruiser


                  ‚Äč

                  Comment


                    #39
                    Thats the "normal" one, 2 wires and it just reverses I think, same as a power window motor works. The other one is basically 2 motors in one physical package. ground through the mount, up or down depends which wire gets power. Its way too complicated for what it needs to do.
                    86 Lincoln Town Car (Galactica).
                    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

                    91 Lincoln Mark VII LSC grandpa spec white and cranberry

                    1984 Lincoln Continental TurboDiesel - rolls coal

                    Originally posted by phayzer5
                    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

                    Comment


                      #40
                      If you don't have one already, get a factory Ford shop manual. It REALLY helps.

                      Comment


                        #41
                        I generally consider that a requirement for owning any old car. shop manual and an EVTM will cover a lot of ground
                        86 Lincoln Town Car (Galactica).
                        5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

                        91 Lincoln Mark VII LSC grandpa spec white and cranberry

                        1984 Lincoln Continental TurboDiesel - rolls coal

                        Originally posted by phayzer5
                        I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

                        Comment


                          #42
                          The Mark VI wouldnít start this morning. I thought it might be the fuel pump inertia switch as the previous owner was having issues with that. But I hear the fuel pump running so thatís not it.

                          I guess this is the beginning of my CFI troubles. Plugs, wires, cap and rotor are new, coil looks to be original. Having never messed with a CFI car Iím not sure where to start.
                          Last edited by mercurygm88; 07-04-2021, 11:54 AM.
                          2002 Mercury Grand Marquis LSE, Sylvania Zevo LED Headlights, MSD Blaster Coils, K&N Cold Air Intake, Dual Exhaust, 3.27's - Dally Driver

                          1983 Lincoln Continental Mark VI, Smog Delete - Summer Cruiser


                          ‚Äč

                          Comment


                            #43
                            Pull a wire and see if you are getting spark.
                            1990 Country Squire - weekend cruiser, next project
                            1988 Crown Vic LTD Wagon - waiting in the wings

                            GMN Box Panther History
                            Box Panther Horsepower and Torque Ratings
                            Box Panther Production Numbers

                            Comment


                              #44
                              Originally posted by Tiggie View Post
                              Pull a wire and see if you are getting spark.
                              Iíll have to grab a spark tester from work and check it out later.
                              2002 Mercury Grand Marquis LSE, Sylvania Zevo LED Headlights, MSD Blaster Coils, K&N Cold Air Intake, Dual Exhaust, 3.27's - Dally Driver

                              1983 Lincoln Continental Mark VI, Smog Delete - Summer Cruiser


                              ‚Äč

                              Comment


                                #45
                                Supposing I get home and find out I have no spark which I assume is the case considering I have fuel where do I go from there? Do these have a pickup coil like the later cars with TFI? I grabbed a coil today because my cost was only $10 but I'm assuming coils just don't up and die like that. I've had coil on plug coils just randomly go from perfect to dead the next day, but not a single wire or cannister coil. Also how do I change this thing? I'm assuming it's just a two wire coil but there's some kind of plastic cover over the top of the coil and I can't really tell how the wires go into it.

                                Thanks in advance for any advice, this one has me worried unfortunately. I'm really considering the possibility that the previous owner bandaged this thing so it would run long enough to sell it and leave the buyer high and dry. I don't trust people.
                                2002 Mercury Grand Marquis LSE, Sylvania Zevo LED Headlights, MSD Blaster Coils, K&N Cold Air Intake, Dual Exhaust, 3.27's - Dally Driver

                                1983 Lincoln Continental Mark VI, Smog Delete - Summer Cruiser


                                ‚Äč

                                Comment

                                Working...
                                X