PotM GrandMarq.NET - Panther Headquarters Forum Index PotM
GMN Chat Room GMN's STORE!! GMN's Gallery Please!!
Results 1 to 18 of 18

Thread: Progress on fixing up my 86 MGM

  1. #1

    Default Progress on fixing up my 86 MGM

    I rescued this poor thing from a destined demo derby. She has a decent amount of rust it's been in MN all it's life so can't really expect anything less. I didn't think the paint would clean up as good as it did. Now I'm trying to track down some tail lights, a bumper, and of course different wheels. Has some issues but runs and drives good thankfully. I noticed the engine light doesn't come on when you turn the key now so I'm sure that bulb is either blown or pulled. The first few days I got her the engine light blinked when idling when engine was hot but it hasn't come on now at all so who knows if the engine light is on, but coolant and oil is good and doesn't knock so...I dunno if I can figure out how to replace the bulb in the cluster I will but to be honest I have no idea how in this thing, but I am trying to fix the other issues it has.

    Plans are full tune up, plugs wires, rotor, cap, already has a fresh oil change I did to it, probably could use a idler pulley, maybe the IAC, and anything else I can think she needs and deserves will be decided in the future lol.

    Click image for larger version. 

Name:	3B92D880-5926-4AA1-8DBB-1FD0499DCE80.jpeg 
Views:	34 
Size:	895.4 KB 
ID:	54616Click image for larger version. 

Name:	214EDD86-0717-4955-BB88-7C27A1A75E64.jpeg 
Views:	33 
Size:	1,021.5 KB 
ID:	54617Click image for larger version. 

Name:	0964195F-53F7-435D-A63A-BE9501AB33EC.jpeg 
Views:	35 
Size:	1.44 MB 
ID:	54618Click image for larger version. 

Name:	BB7FF65E-73E5-47BF-9BF0-2480EF4D0103.jpeg 
Views:	29 
Size:	807.5 KB 
ID:	54619Click image for larger version. 

Name:	C3E7617C-C466-4B5E-A85F-0282BB2311D0.jpeg 
Views:	32 
Size:	1.05 MB 
ID:	54620

  2. #2
    Road Warrior Kodachrome Wolf's Avatar
    Join Date
    Nov 2014
    Location
    Evans, GA
    Posts
    1,640

    Default

    So the Engine light for '86 won't be for any normal "Check Engine" stuff, it's just designed to come on with low oil pressure or high coolant temperature. If it flickers at hot idle, there's a chance the oil pressure is fairly low, like 4-ish PSI. If it keeps doing that and you're using 5W-30 or 10W-30, might be worth trying a 10W-40 or 15W-40 and seeing if it stops.

    Bulb replacement isn't that hard, you've just got to pull the bezel around it, then unbolt the cluster from the dash. You may need to release the speedometer cable to get a little bit more play, but just to replace the bulb, you might not need to pull the whole cluster. You might be able to get your hand to the back and just get at the sockets. If you do have to pull the cluster, I recommend taking the face cover off, and unbolting the shifter indicator from the cluster and swinging it out of the way. It saves you from having to undo the shifter indicator cable from the column.

    My Cars:
    -1987 Grand Marquis Colony Park LS (325K Miles) - April 2017 + September 2019 POTM Winner
    -1989 Sable LS Wagon (88,710 Miles) - Sold
    -1997 Grand Marquis LS (222K Miles) - The Daily Workhorse & March 2015 + January 2019 POTM Winner

  3. #3
    2 decades of DDing Box Panthers, now in a Whale VicCrownVic's Avatar
    Join Date
    Nov 2012
    Location
    Shelby Township, MI
    Posts
    3,212

    Default

    I like it. The first pic I take it is a before pic. If you still have those wheels and tires wheels and tires put some '98ish Mountaineer center caps on (requires three lug nuts per wheel and crushing the dust cap on front hubs). http://www.grandmarq.net/vb/showthre...l=1#post824149

    It's been quite a while since I've been in an '89-earlier dash, but you'll have to remove the dash trim to replace the cluster bulbs.
    Screws or bolts that point straight up on the top lip of the trim and others around the edges of the trim panels. The passenger side panel slips behind the driver side panel and the driver side panel clips into that part of the passenger side panel (possible I have my sides confused) and that is a common break point for those that aren't used to disassembling these things. I don't think the trim around the radio has to be removed, but in case I am remembering wrong there are two screes hiding above the ashtray and maybe a couple more up top.
    After removing at least the trim panel around the cluster (I forget if the p-side needs to be removed due to the interlocking joint with the d-side panel) the screws or bolts holding the cluster in should be obvious.
    Once the cluster is loose don't try to just yank it out. The shift indicator may need to be disconnected, but I don't remember how that is accomplished. Also, the speedometer cable on the back of the cluster needs to be disconnected along with two electrical connectors. The speedo cable I'm not sure what the trick to disconnect that is, but I remember it being a pain (probably because I didn't know the trick to disconnect it).
    The bulbs are 194 bulbs.

    I think you're referring to the red engine light which should only come on for one of two things: low oil pressure or engine coolant temp too high. If the sensors aren't lieing then you may have some troubleshooting to do.

    Edit:what he said.
    Vic

    ~ 1998 Mercury Grand Marquis LS - new DD
    ~ 1991 Mercury Grand Marquis LS "The Scab" - plenty of rot, summer DD
    ~ 1997 GMC Yukon - wannabe winter DD - returning summer 2020, I finally have an engine
    ~ 1991 Mercury Grand Marquis GS "The Ice Car" - Rotting Retired Winter DD
    ~ 1989 Mercury Grand Marquis GS - Rotting Retired DD
    Gone but not forgotten:
    ~ 1988 Country Squire ~ 1987 Ford Crown Vic

  4. #4
    Wagon Addicted Tiggie's Avatar
    Join Date
    Mar 2006
    Location
    Bedford, VA
    Posts
    5,816

    Default

    Looks like a good project. Jack it up and take a good look at the frame to be sure it’s good before investing too much cash in it.

  5. #5
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    39,559

    Default

    If the oil pressure sender is unplugged, the "engine" light will not come on key on, engine off. Its right next to the oil filter, so have a look there for damaged wiring. If its got a real gauge installed the idiot light switch probably wasn't plumbed in so that will cause it too.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  6. #6

    Default

    Sounds good guys, and yeah I haven't had a chance to jack it up yet to look at the frame under neath just been too hot and humid here so waiting till this weekend before I decide if it's worth investing money into her. Hopefully it will the rust isn't too bad on the outside being for a MN car after 30 years, but yeah. Also yes I know the red engine light is for oil and temp only, and yeah the first few days I got it the light flickered on and off at idling and went away right when I gave it throttle. I didn't know how easy these clusters were to take off to replace blown bulbs either so thankfully I'll do that right away too after checking the oil sender when I jack her up. If all goes well she's gonna get the full treatment it deserves lol.

  7. #7

    Default

    Quote Originally Posted by VicCrownVic View Post
    I like it. The first pic I take it is a before pic. If you still have those wheels and tires wheels and tires put some '98ish Mountaineer center caps on (requires three lug nuts per wheel and crushing the dust cap on front hubs). http://www.grandmarq.net/vb/showthre...l=1#post824149

    It's been quite a while since I've been in an '89-earlier dash, but you'll have to remove the dash trim to replace the cluster bulbs.
    Screws or bolts that point straight up on the top lip of the trim and others around the edges of the trim panels. The passenger side panel slips behind the driver side panel and the driver side panel clips into that part of the passenger side panel (possible I have my sides confused) and that is a common break point for those that aren't used to disassembling these things. I don't think the trim around the radio has to be removed, but in case I am remembering wrong there are two screes hiding above the ashtray and maybe a couple more up top.
    After removing at least the trim panel around the cluster (I forget if the p-side needs to be removed due to the interlocking joint with the d-side panel) the screws or bolts holding the cluster in should be obvious.
    Once the cluster is loose don't try to just yank it out. The shift indicator may need to be disconnected, but I don't remember how that is accomplished. Also, the speedometer cable on the back of the cluster needs to be disconnected along with two electrical connectors. The speedo cable I'm not sure what the trick to disconnect that is, but I remember it being a pain (probably because I didn't know the trick to disconnect it).
    The bulbs are 194 bulbs.

    I think you're referring to the red engine light which should only come on for one of two things: low oil pressure or engine coolant temp too high. If the sensors aren't lieing then you may have some troubleshooting to do.

    Edit:what he said.
    I haven't taken the hubcaps off to look but pretty sure I still have those same steel rims, the guy dropped it off at my house with different tires and included those covers he wanted the other tires which were bigger and more better shape basically the tires it has were spare ones for keeping it rolling, but I don't care for those style rims so I was thinking of either classic turbines like my old one had or something more fancy but if anyone has any ideas what would bolt right up to this car please share any.

  8. #8
    fomoco panthers !
    Join Date
    May 2011
    Location
    Bangor,Maine
    Posts
    3,258

    Default

    Just in case you are wondering, those hubcaps are from a 71-72 Ford galaxie /LTD. Surprised the Mercury has lasted this long in MN. Best of luck with it.
    What part of MN are you in ? I owned property very near Intl. Falls. Used to buy my new cars in Wadena, Flew into Brainerd a few times. One time the plane landed at that airport in the winter. Snowing and windy. Must have been at least 0 degrees. Airport was closed. No one around. Everyone standing around calling for cabs. Got to a motel. Called the car dealer to pick up my car the next morning. Salesman didn't want to pick me up because there was a little ice on the road. He picked me up when I told him I would buy him lunch. Picked up my new car then drove 38 hours home. That was just one new car story back in the 80s

  9. #9

    Default

    I live in Duluth, I picked the car up in Hibbing, I'm familiar with Wadena and Int Falls so that's pretty cool to relate, and yeah winters up here can be god awful. Also I took the car for a drive tonight and noticed the engine light flickered again after the drive back when it was idling. So I shut the car off and then the engine light came on with the other lights when priming the ignition so I suppose that would mean the oil sender is either unplugged or rodents chewed the wires? I also noticed the engine light would only flicker in gear, once I put it in park it would stop. I would think even in park it would flicker but maybe it's cause it idles a tad faster when not in gear? Haha either way the bulb still works at least.

  10. #10
    GMN Regular
    Join Date
    Mar 2008
    Location
    Fredericton, N.B. Canada
    Posts
    12,545

    Default

    How many miles on it?
    '79 Continental Town Car
    '90 Crown Victoria LTD
    '94 Crown Victoria
    Quote Originally Posted by Mainemantom View Post
    You may regret selling it. Think it over.

  11. #11

    Default

    Hey guys had the frame inspected, and it's solid. Has some surface rust but the shop said it's in pretty good shape so next week I shall start fixing it up slowly. Probably will only do a few things to it before winter hits cause I am parking it once the winter hits. I am gonna probably have the brakes looked at, the oil pressure and engine shape etc but tune-up, new wheels, eh might hold off. Gonna also get new tail lights and a bumper though too before it'll be parked in October.

    ^Has either 186,000 miles supposedly but being it has only a 5 digit Odo it could be 286k, no way it's 86,000 only lol.
    Last edited by TwiztidRat; 08-02-2020 at 12:49 AM.

  12. #12
    Land Yacht Fundamentalist Hearsesrock427's Avatar
    Join Date
    Apr 2014
    Location
    Upstate NY
    Posts
    580

    Default

    She's beautiful! Reminds me of chocolate '84 that Scott did some work on years ago. Good move on saving her! Interesting how the rear bumper rotted from the inside out and both tail lights got stoved in but the vinyl top is holding up well. Figure you've got at least 3 years before it starts to peel off/delaminate and let water in. Definitely good to have access to storage; I've found these builds cost more and take longer than initially expected. In terms of maintenance however these cars aren't bad- assuming you've caught up on everything. I spend about $400 each year on that front, following the severe duty schedule.

  13. #13

    Default

    My old one I had I spent maybe the same amount a year, some years nothing but than the next year a few $100 more so averaging it a year sounds about right. I love these cars, my old one also had a bad oil leak and at the time I was unaware I drove it on a 300 mile trip and it had less than 2 quarts of oil left thing still never missed a beat. I wish I found one in mint shape but here in MN it's hard to even find them as nice as this one was even though I know it needed fixing up. Plus I only like the 86-87 years so it's been hard to track one of these down. I'm not a fan of the 88-91s and pre 86 they were carb injected obviously lol. I wish more people would appreciate these cars but sadly everyone is sold on marketing and want the newest junk even though new cars will not even make it half the life span of these tanks will

  14. #14

    Default

    Hey guys bad news. I was told a few other things about the shape of the car from the shop owner that the idiot on the phone didn't inform me. Apparently the previous owner never used the actual frame to jack the car up, they jacked it by the floor pan, so the back of the floor is all screwed up, which I did notice there is a large hump on the floor under the back seat, and they told me also the gear box was shot? As in the tranny? cause it works and shifts fine for me, but maybe he meant the housing was damaged? I dunno I still haven't been able to jack it up and look myself cause I have other projects going on and this was gonna be a slow one. My question is what would you do if you found this info out? I'm thinking of just driving it in the ground and look for another in the future that's in more nice shape and just use this one as a beater. I dunno hate to treat it like that but it makes no sense to sink $2k+ and that's to fix all the damage under it. I'm just happy to own one again but I thought just fixing the brakes, and maybe flush the radiator is as far as I should go with it.

  15. #15
    The Brown Blob 87gtVIC's Avatar
    Join Date
    Sep 2008
    Location
    Whitestone, NY
    Posts
    19,325

    Default

    I would look to get further information on transmission.

    I wouldn’t worry about the floor pan.
    ~David~

    My 1987 Crown Victoria Coupe: The Brown Blob
    My 2004 Mercedes Benz E320:The Benz

    Quote Originally Posted by DerekTheGreat View Post
    But, that's just coming from me, this site's biggest pessimist. Best of luck

  16. #16
    I'm an air-conditioned gypsy gadget73's Avatar
    Join Date
    Jan 2005
    Posts
    39,559

    Default

    whack the floor back down with a hammer and a chunk of 2x4. If the metal isn't ripped it should bend back down close enough to where it belongs that the hump in the floor will go away. Not a big deal. If you want it more exactly right you'll probably have to pull the carpet and do more careful hammer and dolly work.

    86 Lincoln Town Car (Galactica).
    5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

    91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

    1984 Lincoln Continental TurboDiesel - rolls coal

    Quote Originally Posted by phayzer5 View Post
    I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

  17. #17
    2 decades of DDing Box Panthers, now in a Whale VicCrownVic's Avatar
    Join Date
    Nov 2012
    Location
    Shelby Township, MI
    Posts
    3,212

    Default

    Gearbox? Steering gearbox?

    As far as becoming a beater, that's what the one I just retired was; a winter beater at that. No negative judgment from me.

    The '98-'02 steel wheels with '98 Mountaineer center caps and snow tires went well with the rugged look of my old car. Although, if you decide to make the car nice, any '98-'02 CV/MGM/LTC wheels will bolt right on. That also gives you a 16" wheel which would allow for the big brake swap ('98-'02 front brakes) later down the road.
    Vic

    ~ 1998 Mercury Grand Marquis LS - new DD
    ~ 1991 Mercury Grand Marquis LS "The Scab" - plenty of rot, summer DD
    ~ 1997 GMC Yukon - wannabe winter DD - returning summer 2020, I finally have an engine
    ~ 1991 Mercury Grand Marquis GS "The Ice Car" - Rotting Retired Winter DD
    ~ 1989 Mercury Grand Marquis GS - Rotting Retired DD
    Gone but not forgotten:
    ~ 1988 Country Squire ~ 1987 Ford Crown Vic

  18. #18

    Default

    Thanks for the suggestion Vic I will look into that, when you mean steelies I thought you meant the old ones from the common 70s and junk. Also guys thanks for informing me about the floor pan fix, I will try pounding that hump out and see how it goes, i'm not giving up on this car yet, well not that I did but my plans almost changed I thought she was too damaged, also is there suppose to be a small hump by the driver seat where you step in? I think that's a hump too I was gonna try pounding out but wanted to make sure it's not something under the car that's suppose to be there. I suppose if I took a pic it could help but right now I'm just gonna focus on pounding the back seat hump first anyways.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
GMN Approved Links!


www.rockauto.com www.adtr.net